Инструменты пользователя

Инструменты сайта


astpanel:designer:unf:modulelistenrecord

Модуль команды "Прослушать запись" обработки MIKO_Asterisk

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
 
	Если сфпФормаТелефон <> Неопределено Тогда
 
		ID_Звонок = ПолучитьИдентификаторЗвонка(ПараметрКоманды);
		Если ID_Звонок <> Неопределено Тогда
			сфпФормаТелефон.ПрослушатьЗвонокПоИдентификатору(ID_Звонок);
		КонецЕсли;
 
	КонецЕсли;
 
КонецПроцедуры
 
Функция ПолучитьИдентификаторЗвонка(Ссылка)
 
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	СобытиеДополнительныеРеквизиты.Значение,
		|	СобытиеДополнительныеРеквизиты.ТекстоваяСтрока
		|ИЗ
		|	Документ.Событие.ДополнительныеРеквизиты КАК СобытиеДополнительныеРеквизиты
		|ГДЕ
		|	СобытиеДополнительныеРеквизиты.Ссылка = &ДокументСсылка
		|	И СобытиеДополнительныеРеквизиты.Свойство В
		|			(ВЫБРАТЬ
		|				ДополнительныеРеквизитыИСведения.Ссылка
		|			ИЗ
		|				ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК ДополнительныеРеквизитыИСведения
		|			ГДЕ
		|				ДополнительныеРеквизитыИСведения.Наименование = &НаименованиеДопСвойства)";
 
	Запрос.УстановитьПараметр("НаименованиеДопСвойства", "ID_Звонок");
	Запрос.УстановитьПараметр("ДокументСсылка", Ссылка);
 
	РезультатЗапроса = Запрос.Выполнить();
	Если Не РезультатЗапроса.Пустой() Тогда
		Выборка = РезультатЗапроса.Выбрать();
		Выборка.Следующий();
 
		Возврат Выборка.Значение;
	КонецЕсли;
 
КонецФункции // ПолучитьИдентификаторЗвонка()
astpanel/designer/unf/modulelistenrecord.txt · Последние изменения: 2014/11/14 22:32 (внешнее изменение)