Инструменты пользователя

Инструменты сайта


astpanel:designer:unf_callbutton

Доработка кнопок вызова в конфигурации УНФ 1.6

Инструкция составлена и проверена с конфигурацией «Управление нашей фирмой, редакция 1.6», версии 1.6.16.215

Для того, чтобы задействовать кнопки вызова рядом с контактной информацией, в формах справочников и документов внесем изменения в общий модуль ТелефонияКлиент:

  • Перейдите к процедурае «ПоддерживаютсяВызовы». В начало процедуры добавьте строки кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если сфпФормаТелефон <> Неопределено Тогда
    		Возврат Истина;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  • Перейдите к процедуре «ПозвонитьПоНомеру». Внесите изменения в процедуру:
    Процедура ПозвонитьПоНомеру(НомерТелефона, Контакт = Неопределено, КонтактРодитель = Неопределено, Событие = Неопределено) Экспорт
    	Перем Ошибка;
    	Перем СтрокаПояснения;
    	
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если сфпФормаТелефон <> Неопределено Тогда
    		сфпФормаТелефон.Позвонить(НомерТелефона);
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
    
    	// *** *** ***
    	// ВНИМАНИЕ ПРОПУЩЕНА ЧАСТЬ ИСХОДНОГО КОДА
    	// *** *** ***
    	
    КонецПроцедуры

В результате доработок появится возможность совершить вызов, нажав на иконку рядом с телефоном:

astpanel/designer/unf_callbutton.txt · Последние изменения: 2019/06/11 13:39 — imal