Инструменты пользователя

Инструменты сайта


astpanel:fastintegration:erp2

Интеграция панели телефонии и журнала звонков в "1С:ERP Управление предприятием 2.2"

Обратно к перечню инструкций

Инструкции составлены для конфигурации:

  • 1С:ERP Управление предприятием 2 (2.2.2.127)

Рекомендуемая версия панели телефонии: 1.4.26.20+
Рекомендуемая версия журнала звонков: 1.0.1.15+

Этап 1. Настройка правил поддержки

Перед началом выполнения работ обязательно сделайте резервное копирование конфигурации и данных!

Для начала следует разблокировать головной объект конфигурации для внесения изменений.

Порядок действий следующий:

  1. Убедитесь, что пользователи завершили работу с программой.
  2. Запустите программу в режиме «Конфигуратор».
  3. Откройте окно настройки поддержки.
  4. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  5. В появившемся окне укажите, что объекты поставщика не редактируются.
  6. Затем для головного объекта конфигурации («УправлениеПредприятием») установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  7. Для общего модуля «ВариантыОтчетовУТПереопределяемый» также установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  8. Закройте окно настройки поддержки

Теперь конфигурация готова к внесению изменений.

Этап 2. Встраивание журнала звонков

  1. Выполните действия «Конфигурация» - «Сравнить и объеденить с конфигурацией из файла»
  2. Выберите файл конфигурации «Module_Statistic_Х_Х_Х_ХХ.protect.cf»;
  3. Снимите флажок со всех объектов конфигурации
  4. Меню «Действия» - «Отметить по подсистемам файла»
  5. Выберите только те подсистемы, которые указаны на скриншоте. Выполните действие «Установить»
  6. Выполните действие «Выполнить»
  7. В появившемся окне нажимаем «Продолжить». Сохраняем отчет сравнения/объединения нашей конфигурации с файлом.
  8. Сравнение и объединение будет завершено.

Изменение типовых объектов

Для завершения этапа встраивания журнала звонков необходимо внести изменения в общий модуль «ВариантыОтчетовУТПереопределяемый».

  1. Открываем общий модуль «ВариантыОтчетовУТПереопределяемый» для редактирования
  2. Переходим в процедуру «ОпределитьРазделыСВариантамиОтчетов»
  3. В конец условия процедуры добавляем строку кода:
    Процедура ОпределитьРазделыСВариантамиОтчетов(Разделы) Экспорт
    	Если НЕ ПолучитьФункциональнуюОпцию("БазоваяВерсия") Тогда
    		Разделы.Добавить(ВариантыОтчетовКлиентСервер.ИдентификаторНачальнойСтраницы(),
    			НСтр("ru = 'Главное'"));
    		
    		// ВНИМАНИЕ!!! Пропущена часть исходного кода!
    
    		Разделы.Добавить(Метаданные.Подсистемы.Производство,
    			НСтр("ru= 'Отчеты по производству'"));
    		//-- НЕ УТ
    		
    		//++ НЕ УТКА
    		Разделы.Добавить(Метаданные.Подсистемы.МеждународныйФинансовыйУчет,
    			НСтр("ru= 'Отчеты по международному финансовому учету'"));
    		//-- НЕ УТКА
    		
    		// МИКО / PT1C / Подсистема "Расширенный журнал звонков"
    		Разделы.Добавить(Метаданные.Подсистемы.МИКО_Телефония);
    		// МИКО / PT1C / Подсистема "Расширенный журнал звонков"
    		
    	КонецЕсли;
    КонецПроцедуры

Этап 3. Встраивание панели телефонии

1. Добавление обработки в подсистему МИКО_Телефония

Замените обработку МИКО_ПанельТелефонииДля1С на внешнюю, которая идет в поставке, она должна называться МИКО_ПанельТелефонииДля1С.

2. Правка модуля управляемого приложения

  1. Откройте модуль управляемого приложения.
  2. Определите глобальную переменную в начале модуля до раздела процедур.
    // PT1C / Панель телефонии Asterisk / Начало
    Перем сфпФормаТелефон Экспорт;
    // PT1C / Панель телефонии Asterisk / Конец 
  3. Перейдите к процедуре «ПриНачалеРаботыСистемы». В конец процедуры вставьте код приведенный ниже.
            // PT1C / Панель телефонии Asterisk / Начало
    	Попытка
    		Отказ = Ложь;
    		// получим форму - основной "модуль" панели телефонии
    		сфпФормаТелефон = ПолучитьФорму("Обработка.МИКО_ПанельТелефонииДля1С.Форма.Форма");
    	Исключение
    		сфпФормаТелефон = Неопределено; //Нет прав на обработку
    	КонецПопытки;
     
    	Если НЕ сфпФормаТелефон = Неопределено Тогда
    		сфпФормаТелефон.ИнициализироватьПанельТелефонии(Истина, Отказ);
    	КонецЕсли; 
    	// проверим успешность инициализации
    	Если Отказ Тогда
    		Сообщить("Не удалось запустить ""МИКО Панель телефонии Asterisk""");
    	КонецЕсли;
            // PT1C / Панель телефонии Asterisk / Конец
  4. Перейдите к процедуре «ПриЗавершенииРаботыСистемы» (создайте процедуру, если ее нет). В конец процедуры вставьте код приведенный ниже.
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если сфпФормаТелефон <> Неопределено Тогда
    		сфпФормаТелефон.ЗавершитьРаботу(Истина);
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец

Этап 4. Завершение этапа встраивания

Сохранение изменений

  1. Обновите конфигурацию базы данных.
  2. В отобразившемся окне нажмите Принять

Обновление конфигурации

  1. Запустите процесс обновления конфигурации. В конфигураторе перейдите в меню «Сервис» - «Параметры», вкладка «Запуск 1С:Предприятие»
  2. В поле «Параметры запуска» укажите строку «ЗапуститьОбновлениеИнформационнойБазы»
  3. Запустите 1С:Предприятие из конфигуратора «Отладка» - «Начать отладку»
  4. Дождитесь завершения обновления
  5. Удалите из параметров запуска строку «ЗапуститьОбновлениеИнформационнойБазы». Перезапустите 1С.

Завершение настройки

Операции требовательны к ресурсам ПК. Лучше их выполнить в нерабочее время.

  1. Запустите 1С Предприятие под полными правами в пользовательском режиме
  2. «Все функции» - «Обработки» - «МИКО: Заполнить индекс телефонов»
  3. Выполните действие «Заполнить коды городов»
  4. Выполните действие «Перезаполнить индекс номеров»

На этом встраивание панели телефонии и журнала звонков в конфигурацию завершено. Теперь можно перейти к настройке продуктов в режиме 1С:Предприятие:

Обратно к перечню инструкций

astpanel/fastintegration/erp2.txt · Последние изменения: 2017/08/22 12:18 — tpor