Инструменты пользователя

Инструменты сайта


doc:1cajam:init

Инициализация компоненты в сеансе 1С:Предприятия 8

Инициализация в толстом клиенте

Есть 2 варианта подключения.

Если библиотека лежит в папке на компьютере, тогда код такой:

    Процедура УстановитьКомпонент()
	ИмяФайла = "C:\Program Files\1cv82\MikoAjam\MikoAjam.dll";	
	ПодключитьВнешнююКомпоненту(ИмяФайла,"Comp" ,ТипВнешнейКомпоненты.Native);
	Компонент = Новый ("AddIn.Comp.MikoAjam");
    КонецПроцедуры

Если библиотека упакована в ZIP архив и добавлена в виде двоичных данных в макет обработки с именем «AddInWindows32», тогда код такой:

    Процедура УстановитьКомпонент()	
        ПутьКМакету = "Обработка.МИКО_ПанельТелефонииДляCRM.Макет.AddInWindows32";
	Если ПодключитьВнешнююКомпоненту(ПутьКМакету,"Comp") Тогда
		Компонент = Новый ("AddIn.Comp.MikoAjam");
	Иначе
		Сообщить("Не удалось подключить внешнюю компоненту");
	КонецЕсли;
    КонецПроцедуры

Инициализация в тонком клиенте и web клиенте

Библиотека вместе с файлом MANIFEST.xml (регистр имеет значение) должна быть упакована в ZIP архив и добавлена в виде двоичных данных в макет обработки с именем «AddInWindows32»

При работе в тонком и web клиенте обязательно использования метода УстановитьВнешнююКомпоненту():

Пример процедуры установки внешнего компонента:

    &НаКлиенте
    // Процедура должна вызываться лишь один раз при первичной установке компонента, либо при обновлении его версии
    Процедура УстановитьКомпонент()
	 АдресАрхиваКомпонента = "Обработка.МИКО_ПанельТелефонииДляCRM.Макет.AddInWindows32";
	Попытка
	  УстановитьВнешнююКомпоненту(АдресАрхиваКомпонента);
	Исключение
	  Сообщить("Не удалось устанвить внешнюю компоненту.");   
        КонецПопытки;
    КонецПроцедуры

При успешном выполнении метода УстановитьВнешнююКомпоненту файлы компонента будут распакованы в каталоги:

Для подключения компонента можно использовать следующую процедуру:

    &НаКлиенте
    Процедура Инициализаровать()
	АдресАрхиваКомпонента = "Обработка.МИКО_ПанельТелефонииДляCRM.Макет.AddInWindows32";
	Если ПодключитьВнешнююКомпоненту(ПутьКМакету,"Comp",ТипВнешнейКомпоненты.Native) Тогда
	  Компонент = Новый ("AddIn.Comp.MikoAjam");
	Иначе
	  СообщитьОтладочнуюИнформацию("Не удалось подключить внешнюю компоненту","");
   	КонецЕсли;
    КонецПроцедуры 

Полезные ссылки

Комментарии

doc/1cajam/init.txt · Последние изменения: 2014/11/14 22:32 (внешнее изменение)