Инструменты пользователя

Инструменты сайта


nightbird:integration-1c-crm3

Встраивание подсистемы телефонии в 1С:CRM 3.0

Данное руководство поможет Вам самостоятельно встроить подсистему телефонии в вашу конфигурацию 1С. Следуйте инструкциям шаг-за-шагом в том порядке, в котором они представлены.

Руководство подходит только для «1С:CRM 3.0». Для других конфигураций (в том числе «1С:CRM 2.0») используйте эту инструкцию.

Данное руководство предполагает наличие у читателя навыков работы с конфигуратором 1С.

Задачи

Шаг 1. Включите возможность изменения конфигурации

Встраивание подсистемы требует разблокировки головного объекта. Не забудьте сделать резервную копию информационной базы перед началом работы.

Для разблокировки головного объект:

  1. Откройте конфигуратор вашей информационной базы.
  2. Откройте окно настройки поддержки, Конфигурация → Поддержка → Настройка поддержки.
  3. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  4. В появившемся окне укажите, что объекты поставщика не редактируются.
  5. Для головного объекта конфигурации установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».

Шаг 2. Встройте подсистему телефонии

Теперь конфигурация готова для внесения изменений. Будьте особенно внимательны на данном шаге, чтобы не повредить объекты Вашей конфигурации.

Для встраивания подсистемы:

  1. Чтобы получить файл конфигурации подсистемы телефонии:
    а. Откройте личный кабинет МИКО https://telefon.miko.ru/personal/update-files/.
    б. Скачайте дистрибутив подсистемы телефонии.
    в. Распакуйте архив.
  2. Откройте окно сравнения и объединения конфигураций:
    а. Выполните команду Конфигурация → Сравнить, объединить с конфигурацией из файла.
    б. Выберите файл подсистемы телефонии.
  3. Снимите флажок с головного объекта.
  4. Отметьте объекты встраиваемой подсистемы :
    а. Откройте окно отбора по подсистемам, Действия → Отметить по подсистемам файла.
    б. Снимите флажок с элемента «ПодсистемаТелефонии».
    в. Установите флажок на элементе «ИнтеграцияCRM».
    г. Установите флажок «Включать объекты родительских подсистем».
    д. Нажмите Установить.
  5. Нажмите Выполнить.
  6. В окне неразрешимых ссылок нажмите Продолжить.
  7. Сохраните изменения, Конфигурация → Сохранить конфигурацию.

Вы можете пропустить настройку карточки клиента, если планируете использовать другую форму обработки звонка.

Для настройки карточки клиента:

  1. Откройте основную форму обработки микоКарточкаКлиента.
  2. В списке реквизитов формы выберите основной реквизит Объект.
  3. Установит тип реквизита в значение, которое будет соответствовать объекту справочника клиентов Вашей конфигурации. В типовых конфигурациях этот справочник может называться Клиенты, Партнеры или Контрагенты.

Шаг 3. Дополните код программных модулей

Чтобы подсистема телефонии могла запускаться и полноценно функционировать нужно внести изменения в программные модули Вашей конфигурации. На этом шаге будут внесены изменения в модули приложений, подсистему отчетов и некоторые другие.

Для настройки работы подсистемы в CRM:

  1. Откройте общий модуль микоТелефонияКлиентПереопределяемый.
  2. Перейдите к процедуре НастроитьИнтеграцию и удалите комментарий со строки интеграции с CRM так, чтобы получилось следующие:
    Процедура НастроитьИнтеграцию(МодулиИнтеграции) Экспорт
     
    	// Интеграция с CRM 3.0
    	МодулиИнтеграции.Добавить("микоТелефонияИнтеграцияCRMКлиент");
     
    КонецПроцедуры
  3. Откройте общий модуль микоТелефонияПереопределяемый.
  4. Перейдите к процедуре НастроитьИнтеграцию и удалите комментарий со строки интеграции с CRM так, чтобы получилось следующие:
    Процедура НастроитьИнтеграцию(МодулиИнтеграции) Экспорт
     
    	// Интеграция с CRM 3.0
    	МодулиИнтеграции.Добавить("микоТелефонияИнтеграцияCRM");
     
    КонецПроцедуры

Для настройки запуска подсистемы:

  1. Откройте модуль управляемого приложения.
  2. Перейдите к разделу объявления переменных и добавьте код:
    // PT1C / Панель телефонии / Начало
    Перем микоКоннекторAPI Экспорт;
    Перем микоПерсональныеНастройки Экспорт;
    // PT1C / Панель телефонии / Конец
  3. Перейдите к процедуре ОбработкаВнешнегоСобытия и добавьте в конец тела процедуры код:
    Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
     
    	// ...
     
    	// PT1C / Панель телефонии / Начало
    	микоТелефонияСлужебный.ОбработатьВнешнееСобытие(Источник, Событие, Данные);
    	// PT1C / Панель телефонии / Конец
     
    КонецПроцедуры
  4. Перейдите к процедуре ПриЗавершенииРаботыСистемы и добавьте в конец тела процедуры код:
    Процедура ПриЗавершенииРаботыСистемы()
     
    	// ...
     
    	// PT1C / Панель телефонии / Начало
    	микоКоннекторAPI = Неопределено;
    	микоПерсональныеНастройки = Неопределено;
    	// PT1C / Панель телефонии / Конец
     
    КонецПроцедуры
  5. Откройте общий модуль сфпСофтФонПроКлиент.
  6. Перейдите к процедуре сфпПодключитьСофтФон и добавьте в начало тела процедуры код:
    Процедура сфпПодключитьСофтФон() Экспорт
     
    	// PT1C / Панель телефонии / Начало
    	Если микоТелефония.Использовать() Тогда
    		Оповещение = Новый ОписаниеОповещения("ПослеИнициализацииКомпонента", микоТелефонияСлужебный);
    		микоТелефонияКлиент.ИнициализироватьКомпонент(Оповещение);
    		сфпОтключитьСофтФон();
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии / Конец
     
    	// ...
     
    КонецПроцедуры

Для настройки обработчика кнопки "Позвонить":

  1. Откройте общий модуль сфпСофтФонПроКлиент.
  2. Перейдите к процедуре сфпПозвонить и добавьте в тело процедуры код:
    Процедура сфпПозвонить(Телефон, Объект = Неопределено, ДанныеЗаполнения = Неопределено) Экспорт
     
    	Если ПустаяСтрока(Телефон) Тогда
    		ПоказатьПредупреждение(, НСтр("ru = 'Не выбран номер телефона!'"), 5);
    		Возврат;
    	ИначеЕсли НЕ сфпПроверитьДоступностьСофтФон(Истина) Тогда
    		Возврат;
    	ИначеЕсли Телефон = сфпСофтФонПроСервер.сфпТекущийВнутреннийНомер() Тогда
    		Возврат;
    	КонецЕсли;
     
    	// PT1C / Панель телефонии / Начало
    	Если микоТелефония.Использовать() И (Не микоПерсональныеНастройки = Неопределено) Тогда
    		микоТелефонияКлиент.Позвонить(Телефон, микоПерсональныеНастройки.ВнутреннийНомер);
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии / Конец
     
    	// ...
     
    КонецПроцедуры
  3. Перейдите к процедуре сфпВыполнитьЗвонокПоНомеру и добавьте в тело процедуры код:
    Процедура сфпВыполнитьЗвонокПоНомеру(ВыбранныйНомер, ДополнительныеПараметры) Экспорт
     
    	Если ВыбранныйНомер = Неопределено Тогда
    		ПоказатьПредупреждение(, НСтр("ru = 'Не выбран номер телефона!'"), 5);
    		Возврат;
    	КонецЕсли;
     
    	// PT1C / Панель телефонии / Начало
    	Если микоТелефония.Использовать() И (Не микоПерсональныеНастройки = Неопределено) Тогда
    		микоТелефонияКлиент.Позвонить(ВыбранныйНомер.Значение.Телефон, микоПерсональныеНастройки.ВнутреннийНомер);
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии / Конец
     
    	сфпПозвонить(ВыбранныйНомер.Значение.Телефон, ВыбранныйНомер.Значение.Контакт, ДополнительныеПараметры.ДанныеЗаполнения);
     
    КонецПроцедуры
  4. Откройте общий модуль сфпСофтФонПроСервер.
  5. Перейдите к процедуре сфпПолучитьМассивТелефоновИФаксов и добавьте в начало тела процедуры код:
    Функция сфпПолучитьМассивТелефоновИФаксов(Ссылка) Экспорт
     
    	// PT1C / Панель телефонии / Начало
    	Если микоТелефония.Использовать() Тогда
    		Возврат микоТелефония.ПолучитьТелефоны(Ссылка);
    	КонецЕсли;
    	// PT1C / Панель телефонии / Конец
     
    	// ...
     
    КонецПроцедуры

Вы можете пропустить настройку панели отчетов, если не планируете использовать журнал звонков.

Для настройки панели отчетов:

  1. Откройте общий модуль ВариантыОтчетовПереопределяемый.
  2. Перейдите к процедуре ОпределитьРазделыСВариантамиОтчетов и добавьте в конец тела процедуры код:
    Процедура ОпределитьРазделыСВариантамиОтчетов(Разделы) Экспорт
     
    	// ...
     
    	// PT1C / Панель телефонии / Начало
    	микоТелефония.ОпределитьРазделыСВариантамиОтчетов(Разделы);
    	// PT1C / Панель телефонии / Конец
     
    КонецПроцедуры

Завершите встраивание подсистемы применив изменения:

  1. Сохраните изменения, Конфигурация → Сохранить конфигурацию.
  2. Обновите конфигурацию базы данных, Конфигурация → Обновить конфигурацию базы данных.
Полезные ссылки:
nightbird/integration-1c-crm3.txt · Последние изменения: 2019/03/01 07:15 — mcvet