Инструменты пользователя

Инструменты сайта


nightbird:integration-1c-managed

Различия

Здесь показаны различия между двумя версиями данной страницы.

Ссылка на это сравнение

Следующая версия
Предыдущая версия
nightbird:integration-1c-managed [2018/08/01 10:19]
mcvet создано
nightbird:integration-1c-managed [2019/04/19 13:57] (текущий)
mcvet
Строка 1: Строка 1:
 +~~NOTOC~~
 ====== Встраивание подсистемы телефонии ====== ====== Встраивание подсистемы телефонии ======
  
Строка 11: Строка 12:
   * [[nightbird:​integration-1c-managed#​shag_2_vstrojte_podsistemu_telefonii|Шаг 2. Встройте подсистему телефонии]]   * [[nightbird:​integration-1c-managed#​shag_2_vstrojte_podsistemu_telefonii|Шаг 2. Встройте подсистему телефонии]]
   * [[nightbird:​integration-1c-managed#​shag_3_dopolnite_kod_programmnyx_modulej|Шаг 3. Дополните код программных модулей]]   * [[nightbird:​integration-1c-managed#​shag_3_dopolnite_kod_programmnyx_modulej|Шаг 3. Дополните код программных модулей]]
 +  * [[nightbird:​integration-1c-managed#​shag_4_nastrojte_knopku_pozvonit|Шаг 4. Настройте кнопку "​Позвонить"​]]
  
 ===== Шаг 1. Включите возможность изменения конфигурации ===== ===== Шаг 1. Включите возможность изменения конфигурации =====
Строка 34: Строка 36:
   - В окне неразрешимых ссылок нажмите **Продолжить**. {{ :​nightbird:​01-08-2018_11-27-48.png?​nolink |}}   - В окне неразрешимых ссылок нажмите **Продолжить**. {{ :​nightbird:​01-08-2018_11-27-48.png?​nolink |}}
   - Сохраните изменения,​ //​Конфигурация -> Сохранить конфигурацию//​.   - Сохраните изменения,​ //​Конфигурация -> Сохранить конфигурацию//​.
 +
 +<​note>​Вы можете пропустить настройку карточки клиента,​ если планируете использовать другую форму обработки звонка.</​note>​
 +=== Для настройки карточки клиента:​ ===
 +  - Откройте основную форму обработки **микоКарточкаКлиента**.
 +  - **В списке реквизитов** формы выберите основной реквизит **Объект**.
 +  - Установит **тип** реквизита в значение,​ которое будет соответствовать **объекту справочника клиентов** Вашей конфигурации. В типовых конфигурациях этот справочник может называться Клиенты,​ Партнеры или Контрагенты. {{ :​nightbird:​06-08-2018_15-16-50.png?​nolink |}}
  
 ===== Шаг 3. Дополните код программных модулей ===== ===== Шаг 3. Дополните код программных модулей =====
Строка 45: Строка 53:
 Перем микоПерсональныеНастройки Экспорт;​ Перем микоПерсональныеНастройки Экспорт;​
 // PT1C / Панель телефонии / Конец</​code>​ // PT1C / Панель телефонии / Конец</​code>​
-  - Перейдите к процедуре **ОбработкаВнешнегоСобытия** и добавьте в конец тела процедуры код: <code 1c>+  - Перейдите к процедуре **ОбработкаВнешнегоСобытия** и добавьте ​**в конец** тела процедуры код: <code 1c>
 Процедура ОбработкаВнешнегоСобытия(Источник,​ Событие,​ Данные) Процедура ОбработкаВнешнегоСобытия(Источник,​ Событие,​ Данные)
   
Строка 55: Строка 63:
   
 КонецПроцедуры</​code>​ КонецПроцедуры</​code>​
-  - Перейдите к процедуре **ПриЗавершенииРаботыСистемы** и добавьте в конец тела процедуры код: <code 1c>+  - Перейдите к процедуре **ПриЗавершенииРаботыСистемы** и добавьте ​**в конец** тела процедуры код: <code 1c>
 Процедура ПриЗавершенииРаботыСистемы() Процедура ПриЗавершенииРаботыСистемы()
  
Строка 67: Строка 75:
 КонецПроцедуры</​code>​ КонецПроцедуры</​code>​
   - Откройте модуль **ОбщегоНазначенияКлиентПереопределяемый**.   - Откройте модуль **ОбщегоНазначенияКлиентПереопределяемый**.
-  - Перейдите к процедуре **ПередНачаломРаботыСистемы** и добавьте в конец тела процедуры код:<​code 1c>+  - Перейдите к процедуре **ПередНачаломРаботыСистемы** и добавьте ​**в конец** тела процедуры код:<​code 1c>
 Процедура ПередНачаломРаботыСистемы(Параметры) Экспорт Процедура ПередНачаломРаботыСистемы(Параметры) Экспорт
   
Строка 84: Строка 92:
 === Для настройки панели отчетов:​ === === Для настройки панели отчетов:​ ===
   - Откройте общий модуль **ВариантыОтчетовПереопределяемый**.   - Откройте общий модуль **ВариантыОтчетовПереопределяемый**.
-  - Перейдите к процедуре **ОпределитьРазделыСВариантамиОтчетов** и добавьте в конец тела процедуры код:<​code 1c>+  - Перейдите к процедуре **ОпределитьРазделыСВариантамиОтчетов** и добавьте ​**в конец** тела процедуры код:<​code 1c>
 Процедура ОпределитьРазделыСВариантамиОтчетов(Разделы) Экспорт Процедура ОпределитьРазделыСВариантамиОтчетов(Разделы) Экспорт
   
Строка 94: Строка 102:
   
 КонецПроцедуры</​code>​ КонецПроцедуры</​code>​
 +
 +Сохраните изменения,​ //​Конфигурация -> Сохранить конфигурацию//​.
 +
 +===== Шаг 4. Настройте кнопку "​Позвонить"​ =====
 +Подсистема телефонии позволяет звонить по нажатию кнопки в 1С. Некоторые конфигурации 1С уже содержат такие кнопки,​ нужно только перехватить их обработчик. Для других подойдет универсальная команда **Позвонить**,​ которую можно встроить в справочники и документы.
 +
 +==== Универсальная команда "​Позвонить"​ ====
 +Команда **Позвонить** отображается в командной панели формы и позволяет совершать исходящие вызовы из справочников и документов. Команда может быть встроена только в справочники,​ которые содержат табличную часть "​Контактная информация"​. А также в документы,​ у которых среди реквизитов есть ссылки на подобные справочники.
 +
 +{{ :​nightbird:​07-08-2018_13-44-24.png?​nolink |}}
 +
 +=== Для настройки универсальной команды "​Позвонить":​ ===
 +  - Откройте свойства общей команды **микоПозвонить**.
 +  - В свойстве **Тип параметра команды** укажите те справочники и документы,​ в которых нужна кнопка "​Позвонить"​. {{ :​nightbird:​07-08-2018_13-32-23.png?​nolink |}}
 +
 +==== Настройка команды "​Позвонить"​ в "​1С:​Управление торговлей"​ ====
 +В конфигурации "​1С:​Управление торговлей,​ ред.11"​ в справочниках партнеров и контактных лиц уже присутствует кнопка для совершения исходящего звонка. Это кнопка может быть использована для звонков с помощью панели телефонии.
 +
 +{{ :​nightbird:​07-08-2018_13-58-00.png?​nolink |}}
 +
 +=== Для настройки кнопки "​Позвонить"​ ===
 +  - Откройте общий модуль **УправлениеКонтактнойИнформациейКлиент**.
 +  - Перейдите к процедуре **ПозвонитьПоТелефону** и добавьте **в начало** тела процедуры код: <code 1c>
 +Процедура ПозвонитьПоТелефону(НомерТелефона)
 +
 + // PT1C / Панель телефонии / Начало
 + Если Не микоПерсональныеНастройки = Неопределено Тогда
 + микоТелефонияКлиент.Позвонить(НомерТелефона,​ микоПерсональныеНастройки.ВнутреннийНомер);​
 + Возврат;​
 + КонецЕсли;​
 + // PT1C / Панель телефонии / Конец
 +
 + // ...
 +
 +КонецПроцедуры</​code>​
 +
 +=== Завершите встраивание подсистемы применив изменения:​ ===
 +  - Сохраните изменения,​ //​Конфигурация -> Сохранить конфигурацию//​.
 +  - Обновите конфигурацию базы данных,​ //​Конфигурация -> Обновить конфигурацию базы данных//​.
 +
 +== Полезные ссылки:​ ==
 +  * [[nightbird:​prepare-1c|Настройка подсистемы телефонии для работы в 1С]]
 +  * [[nightbird:​integration-1c-crm3|Встраивание подсистемы телефонии в 1С:CRM 3.0]]
nightbird/integration-1c-managed.1533118742.txt.gz · Последние изменения: 2018/08/01 10:19 — mcvet