Инструменты пользователя

Инструменты сайта


astpanel:designer:alfaauto6

Интеграция панели телефонии в Альфа-Авто 6

Обратно, к списку конфигураций...

Инструкция составлена и проверена с конфигурацией Альфа-Авто: Автосалон+Автосервис+Автозапчасти КОРП. Версия 6.0.13.33.

Требуется панель телефонии версии 1.4.26.33+

Сделайте РЕЗЕРВНУЮ КОПИЮ информационной базы.

Настройка поддержки

Необходимо включить возможность изменения конфигурации.

Порядок действий следующий:

  1. Убедитесь, что все пользователи завершили свою работу с программой.
  2. Сделайте РЕЗЕРВНУЮ КОПИЮ информационной базы.
  3. Запустите программу в режиме «Конфигуратор».
  4. Откройте окно настройки поддержки «Конфигуратор» - «Поддержка» - «Настройка поддержки».
  5. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  6. В появившемся окне укажите, что объекты поставщика редактируются с сохранением поддержки.

Конфигурация готова к внесению изменений.

Создание новых объектов

  1. Вставьте внешнюю обработку, которая идет в поставке, присвойте ей имя «МИКО_ПанельТелефонииДля1С».
  2. Добавьте новый общий модуль «МИКО_Софтфон».
  3. Установите флажки напротив свойств «Сервер» и «Вызов сервера» модуля.
  4. Скопируйте текст, расположенный по данной ссылке, и вставьте его в модуль «МИКО_Софтфон».

Настройка прав доступа

  1. Добавьте в конфигурацию новую роль «МИКО_Софтфон».
  2. Снимите все отметки о правах выставляемые по умолчанию, а для обработки МИКО_ПанельТелефонииДля1СМИКО_ПанельТелефонииДля1С») установите все права.

Изменение глобального модуля

  1. Откройте модуль управляемого приложения.
  2. Перейдите к процедуре «ПриЗавершенииРаботыСистемы» (создайте процедуру, если ее нет). В конец процедуры вставьте код приведенный ниже.
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если сфпПанельУправления <> Неопределено
    		 И ТипЗнч(сфпПанельУправления) = Тип("УправляемаяФорма") 
    		 И Найти(сфпПанельУправления.ИмяФормы,"Обработка.МИКО_ПанельТелефонииДля1С")<>0 Тогда
    		сфпПанельУправления.ЗавершитьРаботу(Истина);
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец

Изменение плана видов характеристик "Права и настройки"

Добавим в план видов характеристик предопределенный элемент настройки панели телефонии.

  1. Перейдите к плану видов характеристик ПраваИНастройки
  2. Откройте список предопределенных данных
  3. Перейдите к группе общих настроек софтфона СофтФон-сфпОбщиеНастройки
  4. Добавьте подчиненный элемент с параметрами:
    1. Имя МИКО_ИспользоватьПанельТелефонии
    2. Код 60099
    3. Наименование Панель телефонии Asterisk (МИКО)
    4. Тип Булево

Изменение общих модулей

  1. Перейдите к общему модулю «сфпСофтФонПроКлиент»,
  2. К процедуре «сфпПодключитьСофтФон». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	НазваниеПанелиТелефонии = "Панель телефонии Asterisk (МИКО)";
    	Если сфпПанельУправления = Неопределено Тогда
    		МИКО_Софтфон.ВыполнитьПервичнуюУстановку(НазваниеПанелиТелефонии);
    	КонецЕсли; 
     
    	Если МИКО_Софтфон.Использовать(НазваниеПанелиТелефонии) Тогда
    		Если сфпПанельУправления = Неопределено Тогда
    			Попытка
    				сфпПанельУправления = ПолучитьФорму("Обработка.МИКО_ПанельТелефонииДля1С.Форма.Форма");
    				сфпПанельУправления.ИнициализироватьПанельТелефонии(Истина, Ложь);
    			Исключение
    				Сообщить("Не удалось запустить ""Панель телефонии Asterisk (МИКО)""!");
    				Возврат;
    			КонецПопытки;
    		Иначе
    			// Переопределение обработки команды 
    			Если сфпПанельУправления.Открыта() Тогда
    				сфпПанельУправления.Активизировать(); 
    			Иначе
    				сфпПанельУправления.Открыть();
    			КонецЕсли;
    		КонецЕсли; 
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  3. К процедуре «сфпПозвонитьВыбравТелефон». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
     
    		Если ДанныеЗаполнения <> Неопределено
    			И ДанныеЗаполнения.Свойство("Основание") Тогда
     
    			ОснованиеЗвонка = Новый Структура("ОснованиеЗвонка", ДанныеЗаполнения.Основание);
     
    			Если ДанныеЗаполнения.Свойство("Взаимодействие") Тогда
    				ОснованиеЗвонка.Вставить("Взаимодействие",ДанныеЗаполнения.Взаимодействие);
    			КонецЕсли; 
    		КонецЕсли;
     
    		сфпПанельУправления.ПозвонитьВыбравТелефон(СписокОбъектов,,ОснованиеЗвонка);
    		сфпДанныеЗаполнения = ДанныеЗаполнения;
    		Возврат;	
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  4. К процедуре «сфпПроверитьДоступностьСофтФон». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    		Возврат Истина;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  5. К процедуре «сфпПолучитьФайлРазговора». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    		Если сфпПанельУправления<>Неопределено Тогда
    			сфпПанельУправления.ПрослушатьЗвонокПоИдентификатору(ИдентификаторЗаписи);
    		КонецЕсли; 
    		Возврат;	
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  6. К процедуре «сфпПозвонить». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    		ОснованиеЗвонка = Неопределено;
     
    		ДанныеЗаполнения = Вычислить("ДопПараметры");
     
    		Если ДанныеЗаполнения = Неопределено Тогда
     
    			ДанныеЗаполнения = Вычислить("ДанныеЗаполнения");	
     
    		КонецЕсли; 
     
    		Если ДанныеЗаполнения <> Неопределено
    			И ДанныеЗаполнения.Свойство("Основание") Тогда
     
    			ОснованиеЗвонка = Новый Структура("ОснованиеЗвонка, НомерТелефона", ДанныеЗаполнения.Основание, Телефон);
     
    			Если ДанныеЗаполнения.Свойство("Взаимодействие") Тогда
    				ОснованиеЗвонка.Вставить("Взаимодействие",ДанныеЗаполнения.Взаимодействие);
    			КонецЕсли; 
    		КонецЕсли;
    		сфпПанельУправления.Позвонить(Телефон,ОснованиеЗвонка);
    		сфпДанныеЗаполнения = ДанныеЗаполнения;
    		Возврат;	
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  7. Перейдите к общему модулю УправлениеКонтактнойИнформациейКлиент
  8. Добавьте изменения в процедуру ПозвонитьПоТелефону
    Процедура ПозвонитьПоТелефону(НомерТелефона)
     
    	НомерТелефона = СтроковыеФункцииКлиентСервер.ЗаменитьОдниСимволыДругими("()_- ", НомерТелефона, "");
     
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если сфпПанельУправления <> Неопределено Тогда
    		сфпПанельУправления.СделатьЗвонок(НомерТелефона);
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
     
    	// по умолчанию используем "tel".
    	ИмяПротокола = "tel";
     
    	// *** *** ***
    	// ВНИМАНИЕ ПРОПУЩЕНА ЧАСТЬ ИСХОДНОГО КОДА
    	// *** *** ***
     
    КонецПроцедуры

Добавление картинок

В общие картинки добавить

  1. Картинку с именем «МИКО_ЗаписьРазговора»
  2. Картинку с именем «МИКО_Телефон»
  3. Картинку с именем «МИКО_ОтправитьФакс»

Обратно, к списку конфигураций...

Первый запуск

  1. Необходимо запустить 1С под учетной записью администратора 1С.
  2. Перейдите в раздел «Администрирование» → «Настройка параметров учета»
  3. В открывшейся форме выберите группу настроек «Органайзер» → «Софтфон» → «Настроить Софтфон»
  4. Активируйте настройку Использовать сервис СофтФон, сохраните настройки.
  5. Перейдите в раздел «Администрирование» → Настройки пользователей и прав. Перейдите к списку пользователей, найдите текущего пользователя и перейдите в форму «Права и настройки» этого пользователя
  6. В группе настроек Софтфон активируйте настройки:
  • «Использовать СофтФон»
  • «Панель телефонии Asterisk (МИКО)»

Предварительная настройка завершена. Теперь необходимо перезапустить сеанс 1С под администратором и приступить к настройке панели телефонии по инструкции.

Коментарии

astpanel/designer/alfaauto6.txt · Последние изменения: 2019/10/30 12:23 — imal