Инструменты пользователя

Инструменты сайта


nightbird:integration-1c-managed

Встраивание подсистемы телефонии

Данное руководство поможет Вам самостоятельно встроить подсистему телефонии в вашу конфигурацию 1С. Следуйте инструкциям шаг-за-шагом в том порядке, в котором они представлены.

Руководство подходит для «1С:Управление торговлей, ред.11», «1С:Управление нашей фирмой», «1С:CRM, ред.2» и других современных конфигураций построенных на библиотеке стандартных подсистем.

Данное руководство предполагает наличие у читателя навыков работы с конфигуратором 1С.

Задачи

Шаг 1. Включите возможность изменения конфигурации

Встраивание подсистемы требует разблокировки головного объекта. Не забудьте сделать резервную копию информационной базы перед началом работы.

Для разблокировки головного объект:

  1. Откройте конфигуратор вашей информационной базы.
  2. Откройте окно настройки поддержки, Конфигурация → Поддержка → Настройка поддержки.
  3. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  4. В появившемся окне укажите, что объекты поставщика не редактируются.
  5. Для головного объекта конфигурации установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».

Шаг 2. Встройте подсистему телефонии

Теперь конфигурация готова для внесения изменений. Будьте особенно внимательны на данном шаге, чтобы не повредить объекты Вашей конфигурации.

Для встраивания подсистемы:

  1. Чтобы получить файл конфигурации подсистемы телефонии:
    а. Откройте личный кабинет МИКО https://telefon.miko.ru/personal/update-files/.
    б. Скачайте дистрибутив подсистемы телефонии.
    в. Распакуйте архив.
  2. Откройте окно сравнения и объединения конфигураций:
    а. Выполните команду Конфигурация → Сравнить, объединить с конфигурацией из файла.
    б. Выберите файл подсистемы телефонии.
  3. Снимите флажок с головного объекта.
  4. Отметьте объекты встраиваемой подсистемы :
    а. Откройте окно отбора по подсистемам, Действия → Отметить по подсистемам файла.
    б. Снимите флажок с элемента «ПодсистемаТелефонии».
    в. Установите флажок на элементе «микоТелефония».
    г. Снимите флажок «Включать объекты подчиненных подсистем».
    д. Нажмите Установить.
  5. Снимите флажок с подсистемы «ИнтеграцияCRM».
  6. Нажмите Выполнить.
  7. В окне неразрешимых ссылок нажмите Продолжить.
  8. Сохраните изменения, Конфигурация → Сохранить конфигурацию.

Вы можете пропустить настройку карточки клиента, если планируете использовать другую форму обработки звонка.

Для настройки карточки клиента:

  1. Откройте основную форму обработки микоКарточкаКлиента.
  2. В списке реквизитов формы выберите основной реквизит Объект.
  3. Установит тип реквизита в значение, которое будет соответствовать объекту справочника клиентов Вашей конфигурации. В типовых конфигурациях этот справочник может называться Клиенты, Партнеры или Контрагенты.

Шаг 3. Дополните код программных модулей

Чтобы подсистема телефонии могла запускаться и полноценно функционировать нужно внести изменения в программные модули Вашей конфигурации. На этом шаге будут внесены изменения в модули приложений, подсистему отчетов и некоторые другие.

Для настройки запуска подсистемы:

  1. Откройте модуль управляемого приложения.
  2. Перейдите к разделу объявления переменных и добавьте код:
    // PT1C / Панель телефонии / Начало
    Перем микоКоннекторAPI Экспорт;
    Перем микоПерсональныеНастройки Экспорт;
    // PT1C / Панель телефонии / Конец
  3. Перейдите к процедуре ОбработкаВнешнегоСобытия и добавьте в конец тела процедуры код:
    Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
     
    	// ...
     
    	// PT1C / Панель телефонии / Начало
    	микоТелефонияСлужебный.ОбработатьВнешнееСобытие(Источник, Событие, Данные);
    	// PT1C / Панель телефонии / Конец
     
    КонецПроцедуры
  4. Перейдите к процедуре ПриЗавершенииРаботыСистемы и добавьте в конец тела процедуры код:
    Процедура ПриЗавершенииРаботыСистемы()
     
    	// ...
     
    	// PT1C / Панель телефонии / Начало
    	микоКоннекторAPI = Неопределено;
    	микоПерсональныеНастройки = Неопределено;
    	// PT1C / Панель телефонии / Конец
     
    КонецПроцедуры
  5. Откройте модуль ОбщегоНазначенияКлиентПереопределяемый.
  6. Перейдите к процедуре ПередНачаломРаботыСистемы и добавьте в конец тела процедуры код:
    Процедура ПередНачаломРаботыСистемы(Параметры) Экспорт
     
    	// ...
     
    	// PT1C / Панель телефонии / Начало
    	Если микоТелефонияКлиент.ЗапускВозможен() Тогда
    		Оповещение = Новый ОписаниеОповещения("ПослеИнициализацииКомпонента", микоТелефонияСлужебный);
    		микоТелефонияКлиент.ИнициализироватьКомпонент(Оповещение);
    	КонецЕсли;
    	// PT1C / Панель телефонии / Конец
     
    КонецПроцедуры

Вы можете пропустить настройку панели отчетов, если не планируете использовать журнал звонков.

Для настройки панели отчетов:

  1. Откройте общий модуль ВариантыОтчетовПереопределяемый.
  2. Перейдите к процедуре ОпределитьРазделыСВариантамиОтчетов и добавьте в конец тела процедуры код:
    Процедура ОпределитьРазделыСВариантамиОтчетов(Разделы) Экспорт
     
    	// ...
     
    	// PT1C / Панель телефонии / Начало
    	микоТелефония.ОпределитьРазделыСВариантамиОтчетов(Разделы);
    	// PT1C / Панель телефонии / Конец
     
    КонецПроцедуры

Сохраните изменения, Конфигурация → Сохранить конфигурацию.

Шаг 4. Настройте кнопку "Позвонить"

Подсистема телефонии позволяет звонить по нажатию кнопки в 1С. Некоторые конфигурации 1С уже содержат такие кнопки, нужно только перехватить их обработчик. Для других подойдет универсальная команда Позвонить, которую можно встроить в справочники и документы.

Универсальная команда "Позвонить"

Команда Позвонить отображается в командной панели формы и позволяет совершать исходящие вызовы из справочников и документов. Команда может быть встроена только в справочники, которые содержат табличную часть «Контактная информация». А также в документы, у которых среди реквизитов есть ссылки на подобные справочники.

Для настройки универсальной команды "Позвонить":

  1. Откройте свойства общей команды микоПозвонить.
  2. В свойстве Тип параметра команды укажите те справочники и документы, в которых нужна кнопка «Позвонить».

Настройка команды "Позвонить" в "1С:Управление торговлей"

В конфигурации «1С:Управление торговлей, ред.11» в справочниках партнеров и контактных лиц уже присутствует кнопка для совершения исходящего звонка. Это кнопка может быть использована для звонков с помощью панели телефонии.

Для настройки кнопки "Позвонить"

  1. Откройте общий модуль УправлениеКонтактнойИнформациейКлиент.
  2. Перейдите к процедуре ПозвонитьПоТелефону и добавьте в начало тела процедуры код:
    Процедура ПозвонитьПоТелефону(НомерТелефона)
     
    	// PT1C / Панель телефонии / Начало
    	Если Не микоПерсональныеНастройки = Неопределено Тогда
    		микоТелефонияКлиент.Позвонить(НомерТелефона, микоПерсональныеНастройки.ВнутреннийНомер);
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии / Конец
     
    	// ...
     
    КонецПроцедуры

Завершите встраивание подсистемы применив изменения:

  1. Сохраните изменения, Конфигурация → Сохранить конфигурацию.
  2. Обновите конфигурацию базы данных, Конфигурация → Обновить конфигурацию базы данных.
Полезные ссылки:
nightbird/integration-1c-managed.txt · Последние изменения: 2019/04/19 13:57 — mcvet